Docker use 100% cpu in Mac OS Big Sur

Docker is running 100% cpu without any usage from running host.

after updating setting of Full Disk Access, Docker is running correctly

Posted in Uncategorized | Leave a comment

GNS3 to simulate Switch

GNS3 didn’t support Switch, it only supports Router, however, we could use router’s slot with NM-16ESW.

there are some commands different with real switch, however it is enough to do simulate with Multiple Layer Switch (CCNP3) Lab.

cisco-nm-16ESW

Posted in Uncategorized | Leave a comment

cisco router – ‘show’ command in IOS

show

  1. show run with filter text
              
    R1# show run | begin line vty
              
    
  2. show ip interface
              
    show ip interface brief            
              
    
  3. show protocol
              
    show protocol            
              
    
  4. show controllers
              
    show controllers serial 0/0/1
              
    
  5. show version
              
    show version            
              
    

config interface

  1. config interface ip/speed/clock rate/duplex
          
    R2(config)#interface serial 0/0
    R2(config-if)#ip address 10.1.1.2 255.255.255.248
    R2(config-if)#duplex [full|half|auto]
    R2(config-if)#speed [10|100|1000]
    R2(config-if)#clock rate [rate]
    R2(config-if)#no shut
    R2(config-if)#exit
    
    R2# show ip interface brief
          
    
Posted in Uncategorized | Leave a comment

GNS – RIPv2 in router image using dynamips

I import Cisco 7200 and Cisco 3650 image into GNS to do this lab

Cisco-RIP-v2

network schema
R1, R2 10.1.1.1/28
R2, R3 10.1.2.1/28
R2, R3 10.1.3.1/28

PC1, R1 172.16.1.1/24
PC2, R2 172.17.1.1/24
PC3, R3 172.18.1.1/24

R1#conf t
R1(config)#interface Ethernet 2/1
R1(config-if)#ip address 10.1.1.1 255.255.255.248
R1(config-if)#no shut
R1(config-if)#exit

R2(config)#interface fastEthernet 0/0
R2(config-if)#ip address 10.1.1.2 255.255.255.248
R2(config-if)#no shut
R2(config-if)#exit
R2# show ip interface

R2(config)#int serial 2/0
R2(config-if)#clock rate 64000
R2(config-if)#ip address 10.1.2.1 255.255.255.248
R2(config-if)#no shut

R3(config)#int serial 2/0
R3(config-if)#clock rate 64000
R3(config-if)#ip address 10.1.2.2 255.255.255.248
R3(config-if)#no shut

R3(config)#int fastEthernet 1/1
R3(config-if)#ip address 10.1.3.1 255.255.255.248
R3(config-if)#no shut

R1(config)#int ethernet 2/0
R1(config-if)#ip address 10.1.3.2 255.255.255.248
R1(config-if)#no shut

R1(config)#int fa 1/0
R1(config-if)#ip address 172.16.1.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#exit

R2(config)#int fa 1/0
R2(config-if)#ip address 172.17.1.1 255.255.255.0
R2(config-if)#no shut
R2(config-if)#exit

R3(config)#int fa 1/0
R3(config-if)#ip address 172.18.1.1 255.255.255.0
R3(config-if)#no shut
R3(config-if)#exit

PC1> ip 172.16.1.2/24 172.16.1.1
PC2> ip 172.17.1.2/24 172.17.1.1
PC2> ip 172.18.1.2/24 172.18.1.1

PC1> ping 172.18.1.2
PC1> trace 172.18.1.2

# run this setting commands in all routers
router rip
version 2
network 10.1.1.0
network 10.1.2.0
network 10.1.3.0
network 172.16.1.0
network 172.17.1.0
network 172.18.1.0
no auto-summary
exit

R1#show ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

172.17.0.0/24 is subnetted, 1 subnets
R 172.17.1.0 [120/1] via 10.1.1.2, 00:00:15, FastEthernet0/0
172.16.0.0/24 is subnetted, 1 subnets
C 172.16.1.0 is directly connected, Ethernet2/1
172.18.0.0/24 is subnetted, 1 subnets
R 172.18.1.0 [120/1] via 10.1.3.1, 00:00:17, Ethernet2/0
10.0.0.0/29 is subnetted, 3 subnets
C 10.1.3.0 is directly connected, Ethernet2/0
R 10.1.2.0 [120/1] via 10.1.3.1, 00:00:17, Ethernet2/0
[120/1] via 10.1.1.2, 00:00:15, FastEthernet0/0
C 10.1.1.0 is directly connected, FastEthernet0/0

R2#show ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

172.17.0.0/24 is subnetted, 1 subnets
C 172.17.1.0 is directly connected, FastEthernet1/0
172.16.0.0/24 is subnetted, 1 subnets
R 172.16.1.0 [120/1] via 10.1.1.1, 00:00:25, FastEthernet0/0
172.18.0.0/24 is subnetted, 1 subnets
R 172.18.1.0 [120/1] via 10.1.2.2, 00:00:00, Serial2/0
10.0.0.0/29 is subnetted, 3 subnets
R 10.1.3.0 [120/1] via 10.1.2.2, 00:00:00, Serial2/0
[120/1] via 10.1.1.1, 00:00:25, FastEthernet0/0
C 10.1.2.0 is directly connected, Serial2/0
C 10.1.1.0 is directly connected, FastEthernet0/0

R3#show ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

172.17.0.0/24 is subnetted, 1 subnets
R 172.17.1.0 [120/1] via 10.1.2.1, 00:00:10, Serial2/0
172.16.0.0/24 is subnetted, 1 subnets
R 172.16.1.0 [120/1] via 10.1.3.2, 00:00:18, FastEthernet1/1
172.18.0.0/24 is subnetted, 1 subnets
C 172.18.1.0 is directly connected, FastEthernet1/0
10.0.0.0/29 is subnetted, 3 subnets
C 10.1.3.0 is directly connected, FastEthernet1/1
C 10.1.2.0 is directly connected, Serial2/0
R 10.1.1.0 [120/1] via 10.1.3.2, 00:00:18, FastEthernet1/1
[120/1] via 10.1.2.1, 00:00:10, Serial2/0

Posted in Uncategorized | Leave a comment

Mac OS Big Sur 11.2.3 – ifconfig to share vmware network and internet sharing

$ sudo ifconfig bridge100 172.16.196.1 netmask 255.255.255.0
$ sudo ifconfig bridge100 addm en0 addm en1

Posted in Uncategorized | Leave a comment

Packet Tracer – RIP v2 simple lab

Here is topology map,
Two PC – PC0 and PC1

ip scheme
PC0 : 192.168.1.2/24
PC1 : 172.168.1.3/24

Router 0:
GigabitEthenet 0/0: 192.168.1.1/24
S0/0/0: 10.1.1.1/24

Router 1:
GigabitEthenet 0/0: 172.168.1.1/24
S0/0/0: 10.1.1.2/24

rip

Here is example of config interface

1
2
3
4
5
6
7
8
 
Router> en
 
Router# conf t
 
Router(config)# interface GigabitEthernet0/0
ip address 172.168.1.1 255.255.255.0
exit

rip config, run same command on both routers.

1
2
3
4
5
6
7
router rip
version 2
network 10.1.1.0
network 192.168.1.0
network 172.168.1.0
no auto-summary
exit

show_run

Posted in Cisco | Leave a comment

wifi unstable on windows 10

one of way is to change power manage.

 

go to device manager( search control panel ), right click on wifi and go to “power management” and untick “Allow the computer to turn of this device to save power”

 

wifi-powermanagement

Posted in Windows Server | Tagged | Leave a comment

portabledeviceapi.dll error – problem of Windows 10 upgrading to windows 8

after upgrading from windows 8.1 to windows 10, sometime, system will pop up windows dialog and said “There was a problem staring portabledeviceapi.dll”.

rundll-1

The solution is:

Open “Task Scheduler”, under ‘Task Scheduler Library’ having WPD. Delete SqmUpload….

taskSchedule-1

Posted in Uncategorized | Leave a comment

Enable Windows 10 / 2016 long path

As we know, MAX_PATH is always 260 chars in windows.

In windows 10, we could enable in gpedit.msc.

The path is:

Local Group Policy – Computer Configuration – Administrative Templates – System – FileSystem

don’t go to “NTFS” folder, originally, it is located in NTFS. However, it move to “FileSystem” folder.

long-path

Posted in Windows Server | Leave a comment

disable CompatTelTunner.exe

After Install Windows 10 Annual updated package. one progress named  CompatTelTunner.exe takes 100% disk usage. Therefore, it has to been disabled to release some resource.

You can disable the scheduled tasks that starts CompatTelTunner.exe by looking in the Task Scheduler.
Computer Management – System Tools – Task Schedule Library – Microsoft – Windows – Application Experience
or
Start – Run – taskschd.msc
Name: Microsoft Compatibility Appraiser
Location: \Microsoft\Windows\Application Experience
Collects program telemetry information if opted-in to the Microsoft Customer Experience Improvement Program.
Right click on “Microsoft Compatibility Appraiser” and select “Disable” By default, it is set to start if there is ANY network connection.

Posted in Uncategorized | Leave a comment